Переход с 1С:Комплексная автоматизация в 1С:Управление торговлей

Сокращения

1С КА — 1С:Комплексная автоматизация
1С УТ — 1C:Управление торговлей
1С БП — 1С:Бухгалтерия предприятия
1С ЗУП — 1С:Зарплата и управление персоналом
1С УПП — 1С:Управление производственным предприятием
1С ERP — 1С:Enterprise Resource Planning (планирование ресурсов предприятия)

Типичная компания и 1С. Что внедрять и как использовать?

В статье описана типичная российская компания, продающая товары оптом и в розницу. Нужно учитывать торговые операции и отчитываться перед налоговой.

Отвечаем на вопрос «какие программы семейства 1С использовать?» и «как можно сделать миграцию с Комплексной автоматизации в Управление торговлей?».

1С КА или 1С УТ+БП+ЗУП

Перед активно развивающейся торговой компанией рано или поздно встает вопрос о внедрении 1С КА, 1С УПП или 1С ERP.

Если в компании нет сложного производства, не нужны бюджетирование и МСФО, для ведения учета достаточно 1С КА. Комплексная автоматизация это упрощенный вариант 1С УПП. Он подходит для организаций, которым не нужен детальный производственный учет и его планирование.

Альтернатива Комплексной автоматизации — три программы «Управление торговлей», «Бухгалтерия предприятия» и «Зарплата и управление персоналом», работающие в связке.

Главным плюсом 1С КА перед связкой УТ+БП+ЗУП является то, что это единая информационная база и не нужно настраивать синхронизацию между разными базами. Это же является и главным минусом.

Плюсы работы в 1С КА.

  • Все данные находятся в одной информационной базе и не нужно настраивать механизмы обмена данными и возможность проведения целостного анализа!!!
  • Не нужно контролировать корректность и полноту данных в разных базах.
  • В 1С КА есть раздел «Производство», который позволяет вести учет материалов в производстве, выпуск готовой продукции, распределять затраты и работать с переработчиками.

Плюсы работы в связке программ 1С УТ+БП+ЗУП

  • Менеджеры, расчетчики и бухгалтера работают в своих программах и не мешают друг другу, видят только нужные им данные.
  • Если пользователи раньше работали только в 1С БП или УТ, то для работы в КА им может потребоваться дополнительное обучение.
  • Иногда полнота информации в управленческом учете должна отличаться от данных отраженных в бухгалтерском учете, и с этой целью учет удобно вести в разных базах.
  • КА более сложный продукт и стоимость его внедрения выше.
  • Эти программы более популярны, больше специалистов для работы с ними.

Стоимость решения

Сравним цены электронных поставок обоих вариантов на основании прайс-листа от 15.11.2018:

  • Связка 1С УТ+БП+ЗУП — 58 200 рублей (22 600 + 13 000 + 22 600)
  • 1С:Комплексная автоматизация — 61 700 рублей

Стоимость примерно одинаковая.

В БП имеются базовые возможности для кадрового учета и расчета заработной платы. Если их достаточно и 1С ЗУП не нужно приобретать, тогда стоимость УТ+БП составит 35 600 рублей. А это уже ощутимо дешевле стоимости Комплексной автоматизации.

Каждая компания, учитывая указанные преимущества и недостатки, а также свои потребности делает свой выбор.

Очень часто выбирают именно 1С Комплексная автоматизация, и нужно делать миграцию данных с УТ и БП в КА. Но у нас вышло наоборот.

Переход с 1С:КА на 1С:УТ

В нашем случае перед нами стояла прямо противоположная задача. Клиент начал вести учет в КА. На третьем месяце работы решили что больше подходит конфигурация УТ с настроенным  регулярным обменом с БП. Необходимо было перейти с 1С КА в 1С УТ без потери всех данных, введенных за 2,5 месяца работы.

Конфигурацию «1С:Конвертация данных» при реализации перехода не использовали, а пошли по пути обновления конфигурации. Все подсистемы конфигурации 1С УТ практически идентичны подсистемам 1С КА (обратное не верно) . Поэтому решили в базу загрузить конфигурацию УТ без сравнения и объединения.

Была установлена типовая конфигурация 1С КА версии 2.4.3.170 на поддержке.


Делаем копию информационной базы и начинаем.

Делаем копию информационной базы

Первым делом обновили КА 2.4.3.170 до версии КА 2.4.3.172. Сделали это для того, чтобы безболезненно перейти на схожий релиз УТ 11.4.3.172.

Обновляем предыдущую версию

Соглашаемся с обновлением версии поставщика.

Соглашаемся с обновлением версии поставщика

После обновления запускаем базу в режиме 1С:Предприятие, подтверждаем легальность получения обновления и ждем применения обновления.

Подтверждаем легальность получения обновления

Выявили опытным путем, что после перехода на УТ следующем этапе наличие данных в некоторых регистрах сведений вызовет ошибки. Для очистки этих регистров сделали небольшую обработку (ОчисткаРегистров.epf). Код с перечнем регистров представлен ниже:

&НаСервереБезКонтекста
    Процедура УдалитьНаСервере()
	 НаборЗаписей = РегистрыСведений.РеестрДокументов.СоздатьНаборЗаписей();
	 НаборЗаписей.Записать(Истина);
 
	 НаборЗаписей = РегистрыСведений.ДвоичныеДанныеФайлов.СоздатьНаборЗаписей();
	 НаборЗаписей.Записать(Истина);
 
	 НаборЗаписей = РегистрыСведений.ЗначенияГруппДоступаПоУмолчанию.СоздатьНаборЗаписей();
	 НаборЗаписей.Записать(Истина);
 
	 НаборЗаписей = РегистрыСведений.НаличиеФайлов.СоздатьНаборЗаписей();
	 НаборЗаписей.Записать(Истина);
 
	 НаборЗаписей = РегистрыСведений.СклоненияПредставленийОбъектов.СоздатьНаборЗаписей();
	 НаборЗаписей.Записать(Истина);
 
	 НаборЗаписей = РегистрыСведений.КодировкиФайлов.СоздатьНаборЗаписей();
	 НаборЗаписей.Записать(Истина);
 
	 НаборЗаписей = РегистрыСведений.СведенияОФайлах.СоздатьНаборЗаписей();
	 НаборЗаписей.Записать(Истина);
 
    КонецПроцедуры

Теперь можно загрузить конфигурацию УТ 11.4.3.172. В режиме конфигуратора выбираем «Конфигурация» — «Загрузить конфигурацию из файла».

Загружаем конфигурацию из файла

Соглашаемся с предупреждением и нажимаем кнопку «Да»

Соглашение с предупреждением

Снова соглашаемся с обновлением конфигурации.

Соглашение на обновление конфигурации

Конфигурация загрузилась без ошибок.

Далее сделали еще одну обработку для удаления помеченных на удаление записей в справочнике «ИдентификаторыОбъектовМетаданных»

&НаСервереБезКонтекста
	 Процедура Команда2НаСервере()
	    Выборка = Справочники.ИдентификаторыОбъектовМетаданных.Выбрать();
	    Пока Выборка.Следующий() Цикл
	       Если Выборка.ПометкаУдаления Тогда
	           ОбъектД = Выборка.ПолучитьОбъект();
	            ОбъектД.Удалить();
	       КонецЕсли;
	    КонецЦикла;
	 КонецПроцедуры

Возвращаемся в режим 1С:Предприятие. Нам потребуется консоль запросов для 1С. Подойдет любая консоль для приложения на управляемых формах с возможностью выполнения алгоритма по результату выполнения запроса. В консоли нужно выполнить запрос, который из табличной части «Документы» справочника «НастройкиХозяйственных Операций» выберет записи с пустыми ссылками на идентификаторы объекта метаданных. Ниже приведен пример запроса.

Пример запроса

Текст запроса:

ВЫБРАТЬ
	    НастройкиХозяйственныхОперацийДокументы.Ссылка КАК Ссылка,
	    НастройкиХозяйственныхОперацийДокументы.ИдентификаторОбъектаМетаданных КАК ИдентификаторОбъектаМетаданных,
	    НастройкиХозяйственныхОперацийДокументы.НомерСтроки КАК НомерСтроки
	 ИЗ
	    Справочник.НастройкиХозяйственныхОпераций.Документы КАК НастройкиХозяйственныхОперацийДокументы
	 ГДЕ
	    НастройкиХозяйственныхОперацийДокументы.ИдентификаторОбъектаМетаданных.Ссылка ЕСТЬ NULL

Дальше запускаем на исполнение код для удаления всех записей «Объект не найден». Пример кода приведен ниже.

Для Каждого СтрокаРезультата Из РезультатТаблица Цикл

	    Объект1с = СтрокаРезультата.Ссылка.ПолучитьОбъект();
	    Объект1с.Документы.Удалить(Объект1с.Документы[СтрокаРезультата.НомерСтроки-1]);
	    Объект1с.ОбменДанными.Загрузка = Истина;
	    Объект1с.Записать();

	 КонецЦикла;

Чтобы в журналах документов продажи и закупки появились документы нужно перепровести документы.

Документы продажи

В типовой конфигурации УТ есть обработка, в которой можно перепровести нужные документы за требуемый период времени. Лучше перепровести все документы.

Выберем команду «Все функции» как показано на скриншоте.

Команда «Все функции»

В открывшемся окне с объектами конфигурации, в группе «Стандартные» нужно выбрать обработку «Проведение документов». Переносим в правую часть виды документов, которые нужно перепровести и устанавливаем признак «Перепроводить проведенные». Запускаем проведение и ждем.

Проведение документов

После удачного перепроведения документов можно обновить конфигурацию до последнего релиза. В нашем примере мы обновили УТ до релиза 11.4.5.118.

После всех описанных действий, для нормальной работы потребовалось перезаписать всех контрагентов. Если этого не сделать, то в журнале «Документы закупки (все)» в колонке «Контрагенты» не отображалось наименование контрагента. Хотя в документе он был указан.

После того как Заказчик был переведен на УТ описанным способом, была выполнена настройка синхронизации УТ с базой 1С:Бухгалтерия предприятия.

Надеемся, что кейс пригодится Вам в Вашей работе.

Наш опыт позволяет выполнять интеграции любой сложности для различных конфигураций 1С. Напишите или позвоните, и мы решим Вашу задачу.

Оцените статью:
  • Теги:
Заказать работы по 1С

Вы можете войти, используя аккаунт одной из социальных сетей